Discussion

33
Views
feenr Member since 2010 53 posts
PEGA
Posted: 10 months ago
Last activity: 10 months 1 week ago

After upgrade deployment manager to 4.5, repository diagnostics is failing

After upgrade deployment manager to 4.5, repository diagnostics is failing with error 'The artifact cannot be read from the repository'.

This issue is often seen if the candidate systems are in an older version of PegaDevOpsFoundation, such as when you are using the lastest version of Deployment Manager to manage pipelines where the target environments are on platform 7.4.

  • ​​If candidates are not upgraded to PegaDevopsFoundation 4.5 and browse artifacts displays the related artifacts, then user can safely ignore this error.
  • This issue has been fixed in Deployment Manager version 4.6
  • Note that: Deployment Manager is still backward compatible in terms of functionality, but in diagnostics check on orchestrator repository is failing due to additional checks made on new version. This issue will be fixed if candidates are upgraded to PegaDevopsFoundation 4.5.

This is a frequently asked question about Deployment Manager. Find more answers here.

DevOps Developer Knowledge Share
Share this page LinkedIn