Discussion

2
Replies
135
Views
Close popover
Johan Grande (GrandeJ1)
Sopra

Sopra
FR
GrandeJ1 Member since 2015 12 posts
Sopra
Posted: April 9, 2015
Last activity: April 10, 2015
Closed

Can't get unit testing to work in 7.1.7 PE

Hi,

I am trying to understand unit testing in Pega. I created a simple activity "Id" that I would like to test. Id has one required in parameter X, one out parameter Y, and does Property-Set(Param.Y, Param.X).

I tried testing from "menu Actions > Run" and from "tab Test Cases > Record new test case". I chose various parameters and tried entering various values (including no value) for X and Y, but I can't get anything other than an "ActivityStatusSuccess" window that shows a green checkmark and says: Status: good; Message: The Operation completed successfully, but returned no content; [...].

How can I get something meaningful, e.g. a test failing if I enter different values for X and Y?

Also maybe the help [1] should be updated; what it describes doesn't seem to match the existing interface.

[1] https://pdn.pega.com/sites/pdn.pega.com/files/help_v717/procomhelpmain.htm#rule-/rule-obj-/rule-obj-activity/testing.htm

DevOps Testing Applications
Moderation Team has archived post,
Close popover This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Discussion, please write a new Discussion.