Discussion

3
Replies
564
Views
VigneshAravind Member since 2007 28 posts
Cognizant
Posted: 4 years ago
Last activity: 3 years 11 months ago
Closed

Could not resume "rules upgrade" using resume.sh

We were performing a Rules Upgrade from 6.2.1 to 7.1.9; the upgrade.sh stalled due to lack of table space ( UNIX + ORA Setup ). We added some table space and tired to resume the upgrade with resume.sh

Before resuming the upgrade we ensured to update the DB credentials in the setupdatabase.properties since the DB password changes every 24 HRs in our environment.

When resume.sh tried to establish a new connection with DB it failed and threw the error shown below.

We verified the prbootstrap.properties and it had the new credentials that we had updated in the setupdatabase.properties

Also we tried resume.sh --dbPassword option to overwrite any old password that the upgrade.sh had stored earlier in one of the properties file ( assuming the upgrade process is still using the old password. )

Kindly post your suggestions.

[java] Apr 27, 2016 5:39:20 AM com.pega.pegarules.internal.bootstrap.PRBootstrap
[java] SEVERE: Problem during method invocation (main)
[java] com.pega.pegarules.pub.PRException: A problem occurred.
[java] From: (unknown)
[java] at com.pega.pegarules.deploy.external.util.Application.main(Application.java:506)
[java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
[java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
[java] at java.lang.reflect.Method.invoke(Method.java:601)
[java] at com.pega.pegarules.internal.bootstrap.PRBootstrap.invokeMethod(PRBootstrap.java:370)
[java] at com.pega.pegarules.internal.bootstrap.PRBootstrap.invokeMethodPropagatingThrowable(PRBootstrap.java:411)
[java] at com.pega.pegarules.boot.internal.extbridge.AppServerBridgeToPega.invokeMethodPropagatingThrowable(AppServerBridgeToPega.java:223)
[java] at com.pega.pegarules.boot.internal.extbridge.AppServerBridgeToPega.invokeMethod(AppServerBridgeToPega.java:272)
[java] at com.pega.pegarules.pub.PegaRULES.main(PegaRULES.java:85)
[java] Caused by: com.pega.pegarules.pub.PRRuntimeException: Error determining the mode of PRPC install from database.
[java] at com.pega.pegarules.data.internal.PRDataProviderImpl.isMultiTenantEnvironment(PRDataProviderImpl.java:1135)
[java] at com.pega.pegarules.deploy.internal.archive.ParUtilsImpl.setStageDirectory(ParUtilsImpl.java:219)
[java] 2016-04-27 05:39:20,679 [ main] [ ] [ ] ( external.util.Application) ERROR - A problem occurred. at com.pega.pegarules.deploy.internal.archive.ParUtilsImpl.copyFileToVfsRoot(ParUtilsImpl.java:315)
[java]
[java] com.pega.pegarules.pub.PRRuntimeException: Error determining the mode of PRPC install from database. at com.pega.pegarules.deploy.external.util.Application.main(Application.java:424)
[java]
[java] ... 9 more
[java] at com.pega.pegarules.data.internal.PRDataProviderImpl.isMultiTenantEnvironment(PRDataProviderImpl.java:1135)
[java] at com.pega.pegarules.deploy.internal.archive.ParUtilsImpl.setStageDirectory(ParUtilsImpl.java:219)
[java] Caused by: com.pega.pegarules.pub.database.DatabaseException: Database-General Problem encountered when getting connection for database pegarules 1017 72000 ORA-01017: invalid username/password; logon denied

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Low-Code App Development Upgrades
Moderation Team has archived post
Share this page LinkedIn