Discussion

3
Replies
261
Views
Close popover
Ajith Appukuttan (AjithA82)
Capital One

Capital One
US
AjithA82 Member since 2015 2 posts
Capital One
Posted: June 24, 2015
Last activity: July 18, 2015
Closed

Issues in creating a new Custom Log

Hi All,

 I am trying to create a new Custom log for my application. I tried to add a new Appender in the prlogging.xml and restarted the APP server. But the Custom message still goes to Pegarules Log file.Here is the prlogging.xml

Pega Appender

 

<appender name="ASYNC" class="com.pega.apache.log4j.AsyncAppender">
        <param name="BufferSize" value="1024"/>
        <param name="Blocking" value="false"/>
        <filter class="com.pega.apache.log4j.varia.LevelMatchFilter">
            <param name="LevelToMatch" value="ALERT"/>
            <param name="AcceptOnMatch" value="false"/>
        </filter>
        <appender-ref ref="CONSOLE"/>
        <appender-ref ref="PEGA"/>
    </appender>

Custom Appender

<appender name="CHIPS-ASYNC" class="com.pega.apache.log4j.AsyncAppender">
            <param name="BufferSize" value="512"/>
            <param name="Blocking" value="false"/>
            <filter class="com.pega.apache.log4j.varia.LevelMatchFilter">
                <param name="LevelToMatch" value="INFO"/>

                <param name="StringToMatch" value="CHIPS" />
                <param name="AcceptOnMatch" value="true"/>
            </filter>
            <filter class="com.pega.apache.log4j.varia.DenyAllFilter"/>
            <appender-ref ref="CHIPS-SERVICE"/>

Dialy roling

<appender name="CHIPS-SERVICE" class="com.pega.pegarules.priv.util.DailySizeRollingFileAppenderPega">
          <param name="FileNamePattern" value="'/prod/msp/logs/pega_logs/msp_pega_das_01/chips_logs/CHIPS-SERVICE-'yyyy-MMM-dd'.log'"/>
          <param name="MaxFileSize" value="50MB" />
          <layout class="com.pega.apache.log4j.PatternLayout">
           <param name="ConversionPattern" value="%d [%20.20t] [%10.10X{pegathread}] [%20.20X{tenantid}] [%20.20X{app}] (%30.30c{3}) %-5p %X{stack} %X{userid} - %m%n"/>
          </layout>
     </appender>

 

I created a aciviry to add log message with log level infoforced and message starts with CHIPS. But still the log message goes to Pega Rules. Any help?

 

 

Moderation Team has archived post