Discussion

250
Views
ERNSG Member since 2012 1 post
PEGA
Posted: 4 months ago
Last activity: 4 months 3 weeks ago

Oracle Database 19c is supported in Pega Platform releases before 8.4

Hi all,

Oracle has announced the sunset of patches and support for version 12.2.01 (12c) of the Oracle database as of November 2020. See https://support.oracle.com/knowledge/Oracle%20Database%20Products/742060_1.html.

We've received questions about Pega's support for the next "Long-Term" release, Oracle Database 19c. Pega Platform 8.4 has been certified with Oracle 19c in the Platform Support Guide

Older Pega Platform releases have not been certified with 19c, in accordance with our forward-looking platform support policy. However, our testing of 19c (and 18c previously) uncovered zero compatibility issues. We have every reason to believe a system upgraded from 12c to 19c will be successful. Pega will support any system that has upgraded from Oracle 12c to 19c, regardless of the Pega Platform version.

Using new features provided by 19c does require Pega Platform 8.4+.

This is not a change in policy and is consistent with the general statements in our Platform Support Guide. But the volume of questions has been high, so I thought it would be worth publishing this extra note.

 

Thank you!

 

***Edited by Moderator Marissa to add the Developer Knowledge Share tag***

Pega Platform 8.1 Developer Knowledge Share
Share this page LinkedIn