Discussion

8
Replies
1136
Views
MCCAR1 Member since 2009 26 posts
PEGA
Posted: September 10, 2015
Last activity: August 28, 2016
Closed

Pega 7 CMIS/atom integration with Alfresco Community Edition 5.0

Hi,

I'm trying to configure CMIS integration over atompub with Alfresco Community Edition 5.0 but I'm having problems.

 

My environment:

Pega 7 instance is ML7 personal edition running locally on my laptop.

Alfresco Community 5.0 is also running locally on my laptop.

I used the Alfresco Community Win 64 installer - creates separate Tomcat/PostrgreSQL instances as Windows services so I used Advanced mode to change all the ports from the defaults so there is no conflict with the ones used by Pega 7.

I can log into Alfresco and create a site and documents using the web tool that ships with the product so I have every reason to believe that the install is good.

 

On Pega I created an atom server instance. However the Test Connectivity button gives me a Fail.

I checked that the two Windows services (one for Tomcat and one for PostgreSQL) are started - they are.

The URI that I am using is:

http://127.0.0.1:8090/alfresco/api/-default-/public/cmis/versions/1.1/atom

(I have also tried localhost instead of 127.0.0.1 in case it makes any difference but it doesn't)

This is the URI that the Alfresco documentation website says to use for version 5.0 (the URI you have to use is different for each version of product).

The Fail on testing connectivity contains the following text:

Status fail
Message com.pega.apache.axiom.om.OMElement.setFirstChild(Lcom/pega/apache/axiom/om/OMNode;)V
Operator ID mccar1
Requestor ID H2B599A71C357B27187467E740D5C2DA5
Timestamp Thu Sep 10 10:39:34 BST 2015
Engine Version PegaRULES 7.10 ML7 (coreAssemblyCached_717_644)

 

Interestingly if I try the URI specified by Alfresco for use with version 3.x I get a different error:

Test Connectivity For Data-Admin-Connect-AtomServer.AlfrescoServer 

Overall Result
Fail 
Couldn't connect to Atom server located at http://localhost:8090/alfresco/service/cmis <p> 404-Not Found 

List of Steps
Step Result
Establish Connection to Atom Server  Fail 
Get Service Document  Not attempted 

Components Tested
Description Value
atomServerUserID  admin 
atomServerURI  http://localhost:8090/alfresco/service/cmis 

Response
Response       

 

Has anybody else tried this configuration? How did you get it working?

 

Regards,

Rob

 

 

Data Integration
Moderation Team has archived post
Share this page LinkedIn