Discussion

51
Views
Konstantin Serditov (Konstantin Serditov)
PEGA

Pegasystems Inc.
Konstantin Serditov Member since 2016 3 posts
PEGA
Posted: February 10, 2021
Last activity: February 11, 2021
Posted: 10 Feb 2021 10:09 EST
Last activity: 11 Feb 2021 5:21 EST

Resolving Pega Robotics Package Server "the request entity is too large" error

When you use Pega Robotics Package Server installed on IIS, you may get the following error trying to deploy new automation package from Pega Robot Studio or from Visual Studio with Pega Robotics Plugin:

Error "The page was not displayed because the request entity is too large."

Studio log file contains the following text:

ERROR | 2021-02-06 00:37:15,485 |       1 | 1   | 6948  | STA   | OSS                       |                                |                                | PackageServerClient.DeployPackageToServer: The page was not displayed because the request entity is too large.
ERROR | 2021-02-06 00:37:15,487 |       1 | 1   | 6948  | STA   | OSS                       |                                |                                | Error publishing package to Pega Server
ERROR | 2021-02-06 00:37:15,495 |       1 | 1   | 6948  | STA   | Exception                 |                                |                                | The page was not displayed because the request entity is too large., Verbose Message: General Information


Diagnostic Info:
Diagnostic.MachineName: RDA-02
Diagnostic.FullName: OpenSpan, Version=19.1.0.0, Culture=neutral, PublicKeyToken=f5db91edc02d8c5e
Diagnostic.AppDomainName: DefaultDomain
Diagnostic.WindowsIdentity: DOMAIN\username
Diagnostic.ApplicationName: Pega Robot Studio

Exception Information



1) Exception Information
*********************************************
Exception Type: System.ApplicationException
Message: "The page was not displayed because the request entity is too large."
Data: IDictionary (System.Collections.ListDictionaryInternal) with 0 items
TargetSite: Void PublishPackageToManagementConsole(System.String, Byte[], System.Collections.Generic.List`1[OpenSpan.Studio.Solution.DesignProject+DeploymentProfile], System.String)
HelpLink: NULL
Source: "OpenSpan.Studio"
HResult: -2146232832

StackTrace Information
*********************************************
   at OpenSpan.Studio.Solution.DesignProject.PublishPackageToManagementConsole(String packageName, Byte[] packageData, List`1 profiles, String packageComment)

This happens because of IIS configuration that does not allow requests larger than specific limit (30 mb for default installation).

To resolve the issue, verify size of your deployment package, check and change two configuration settings in IIS. Here are the detailed steps:

  1. Open IIS Manager
  2. Select the Package Server site
  3. Double click “Configuration Editor”
  4. Select system.webServer and then serverRuntime
  5. Check and modify the uploadReadAheadSize value in bytes (so that its value is larger than package size or use maximum value 2147483647) maxRequestEntityAllowed
  6. Click “Apply”
  7. Select the Package Server site once again
  8. Double click "Request Filtering"
  9. Click "Edit Feature Settings..."
  10. Check and modify the Maximum allowed content length (Bytes) (so that its value is also larger than package size or use maximum value 2147483647)maxAllowedContentLength
  11. Click "OK"
  12. Restart Package Server site
***Edited by Moderator Marissa to add the Developer Knowledge Share tag***
Pega Robotic Automation 19.1 Robotic Process Automation Cross-Industry Lead System Architect Developer Knowledge Share