Discussion

3
Replies
276
Views
Close popover
Raghu Tallam (tallr1)
PEGA
Sr. Manager, Consulting
Pegasystems Inc.
IN
tallr1 Member since 2013 9 posts
PEGA
Posted: February 7, 2016
Last activity: April 6, 2018
Closed

Upgrade, not Update if using IAC? (Pega 7.1.4 to Pega 7.1.9)

Hello Upgrade Center experts,

We are planning to upgrade from Pega 7.1.4 to Pega 7.1.9 or later. As part of this, we would also upgrade CPM, CPMFS Strategic Applications. We use IAC extensively and also have BIX installed.

I thought, move from Pega 7.1.4 to latest version of Pega 7.1.x is considered ML Update and have to use "Pega719_UpdateGuide.pdf" guide; however in the same document on Page 4, it says the below:

--------------------------------------------------------------------------------------------

Updates do not include additional products: You must upgrade if your system includes Pega Web Mashup (formerly Internet Application Composer (IAC) or Business Intelligence Exchange
(BIX).

--------------------------------------------------------------------------------------------

Question 1: Please confirm as per above statement, if we must follow the Upgrade guide "Pega719_UpgradeGuide.pdf", not Update guide, because we use IAC.

Question 2: The version of IAC and BIX provided, "pxBIX_07.10.01.zip" under Additional_Products folder, as part of distribution package in 7.1.4 & 7.1.9 seems to be same.

Even if it's not same, the Pega-BIX ruleset jar can be deployed independently after performing an Update from Pega 7.1.4 to Pega 7.1.9. So, I do not understand the reason for performing Upgrade, instead of Update, if we use BIX.

Is this because, core Pega engine code has undergone BIX related changes from 7.1.4 to 7.1.9, not just Pega-BIX ruleset? Please clarify.

Look forward to your replies.

Thanks

Raghu

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

System Administration Upgrades
Moderation Team has archived post,
Close popover This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Discussion, please write a new Discussion.