Discussion

4
Replies
1187
Views
VigneshAravindhan Member since 2014 6 posts
Cognizant
Posted: 4 years ago
Last activity: 4 years 5 months ago
Closed

Upgrading Activities built on JAVA API Version 02

Setting the context ...

We are upgrading from 6.2.1 to 7.1.9

In the 6.2.1 application we have an activity that was originally built in 5.X.X using JAVA API Version 02

This activity uses a function called sendData(String,String)

This function has been deprecated (OR) has been replace by another function with a similar name in JAVA API Version 03-02 , we know this because when we attempt to change the JAVA API Version from 02 (to) 03-02 in the concerned activity it throws an error. Such changes are possible in 6.2.1 because it provides a drop down to choose a JAVA API Version in all activity rule forms under the 'Steps' tab; this is only meant for backward compatibility with V5. No such option is available in 7.X.X

Questions I have are ...

  1. Is this going to be a problem post upgrade to 7.1.9 ?
  2. Will the upgrade script take care of function name changes between JAVA API versions (02 Vs 03-02) ?
  3. If the scripts do not take care of this then should we take care of the changes manually as part of pre-upgrade steps ?
  4. Is there a list somewhere in PDN (OR) with 'ECS Team' that has "all deprecated functions + all functions that have been renamed" in JAVA API 03-02 (Vs API 02)?

NOTEs #

  • To know which JAVA API Version is being used by your activity; Actions >>> View XML >>> Pop-up >>> Lookup xml tag pyJavaGenerateAPIVersion
  • By default any activity built in V6/V7 can only use JAVA API 03-02

REFERENCE #

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Low-Code App Development Upgrades
Moderation Team has archived post
Share this page LinkedIn