Question

1
Replies
51
Views
Sudheer Meetakoti (SudheerM8610)
Wellsfargo

Wellsfargo
IN
SudheerM8610 Member since 2021 2 posts
Wellsfargo
Posted: April 16, 2021
Last activity: April 21, 2021
Posted: 16 Apr 2021 3:41 EDT
Last activity: 21 Apr 2021 12:36 EDT

Activities -Requires authentication in security Tab

When we write an new activity or update an old activity in 8.5.x we are forced to check the option "Require Authentication to run" else a severe warning is thrown. 

Otherwise if we are using allow direct invocation check box, we are again forced to use a privilege to avoid  severe warning. 

This is not the case until 8.4 version. we have upgraded our application to 8.5.x and the compliance score has come down sharply. Any specific reason why we need to use this option for simple utilities or flow utilities?

I think this is a bug in 8.5.x to use any of these options or any specific reason to use these options. can someone please help how to turn this off or any workaround.

***Edited by Moderator: Pooja Gadige to add platform capability tag***
Pega Platform 8.5.2 Security