Question

1
Replies
1699
Views
Francisco Leal (FranciscoL4069)
Accenture

Accenture
BR
FranciscoL4069 Member since 2015 8 posts
Accenture
Posted: September 26, 2018
Last activity: October 5, 2018
Posted: 26 Sep 2018 15:51 EDT
Last activity: 5 Oct 2018 11:40 EDT
Closed

Authentication requirement on the Authentication Activity

In the "PortletAuthentication" activity. the SSO solution just work if I run at first time, if I logout and log on again doesn't load the information. the information is a PageList that inside there has a Data Page that load a Report Definiton.

but in the "pxRetriveReportData"(ootb) Activity is checked the "Required Authentication to Run" Checkbox.

the log show this Message when the Page List runs(just non-Working scenario):

"Only authenticated client may start this activity: RULE-OBJ-ACTIVITY RULE-OBJ-REPORT-DEFINITION PXRETRIEVEREPORTDATA..."

The Sso Works but don't retrive the data of the PageList, When this problem of "pxRetriveReportData" happens. In the Log file in the attachments show when retrive data and not retrive.

follow in attachments the Log file.

Note:
The property Pagelist load the workbaskets and set into the "workbasketlist" of the user(we use this because exist a especific logic to set each WorkBasket for each user. So we use this Report definition).

the question is:

Why at the first time this activity "pxRetriveReportData" runs?

And how can I solve this problem?

Thanks.

***Edited by Moderator: Pallavi to update platform capability tags***

Pega Customer Service Reporting Security System Administration
Moderation Team has archived post, This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.