Question

4
Replies
60
Views
JohanH55 Member since 2018 11 posts
Ernst & Young
Posted: 6 months ago
Last activity: 4 months 4 weeks ago
Solved

Deployment Manager pipeline stops working every couple of days, forcing a server restart

Hi,

We use version 4.6 of the Deployment Manager. Our pipeline work fine for a while and then stops working. Running Pipeline Diagnostics then usually shows that Orchestrator is unable to contact Quality Assurance. Occasionally it would also show that Orchestrator is unable to contact Development, which is interesting because Deployment Manager and Development are on the same installation. I include some log file output from when both Development and Quality Assurance failed.

The log files show for the Quality Assurance server:

{"ID":"DIAG_009","status":"FAIL","errorMessage":"QualityAssurance environment was not able to connect to the orchestrator.","description":"Callback n/w issue to orchestrator","test":"CONNECTIVITY"...

...and for Development:

"ID":"DIAG_009","status":"FAIL","errorMessage":"Development environment was not able to connect to the orchestrator.","description":"Callback n/w issue to orchestrator","test":"CONNECTIVITY"...

It's like the Orchestrator stops working and is unable to recover so that callbacks fail. Restarting both tomcat instances resolved the issue. No connectivity issues were reported by anyone at the time and people were inconvenienced by the restart. Telnet to applicable ports and connectivity tests to file-based repos always succeeds.

Does anyone have a clue? 

Pega Customer Service 8.3 Low-Code App Development Installation and Deployment Financial Services System Architect
Share this page LinkedIn