Question

1
Replies
84
Views
IMURPALVICKY Member since 2013 27 posts
Tata Consultancy Services
Posted: November 12, 2017
Last activity: November 16, 2017
Closed

DevOps API pzImport is not working as expected for preexisting rules

Hi Team,

I using the import api of PEGA 7.2.1 for importing the product archive in to target server, Not sure of this below error

Error: Save Failed: Database-Saver-Insertfail (RULE-FILE-BINARY WEBWB XYZ-FW-NPFW-WORK!VDX #20160307T160016.321 GMT)

Note: I have made many successfull import to the target server, this is the first case among it , appreciate if you can advice on this, thanks in advance

when the same archive is done through front end

⇒ Pre-existing Rule Conflicts

WARNING: These rules already exist in the system in a different ruleset.

The recommended best practice is to refactor the existing application that references these rules or to repackage your bundle without the affected rules.

Alternatively, work with your application team to decide which ruleset should contain the affected rule(s). You may continue to load the rules by selecting them below. However, this will replace the existing rules on the system with the same name and may cause incompatibilities with the existing application that references those rules. If you choose not to load the rules, the rules that reference these instances may not work correctly.

Replace

Category

Rule Type

Instance

Existing Rule Set

Archived Rule Set

Technical

Rule-File-Binary

WEBWB XYZ-FW-NPFW-WORK!VDX #20160307T160016.321 GMT

XYZNPWork:01-02-11

XYZNPWork:01-18-11

First of all i am not sure why this screen is showing even if the ruleset are different after this is successfull it updates the XYZNPWork:01-02-11 with XYZNPWork:01-18-11, I was expecting to see two instance in different version not sure why this is considered as conflict

DevOps
Moderation Team has archived post
Share this page LinkedIn