Question

2
Replies
193
Views
ArunS150 Member since 2013 3 posts
BPMCompany
Posted: March 5, 2019
Last activity: March 7, 2019
Closed
Solved

DevOps Pipeline instance not moving to next stage

We have set up a pipeline with Pega infinity and deployment manager version 4.3 on tomcat and we use azure storage as a repository. The diagnostics of the pipeline is all green. When we trigger the CD pipeline we see that the artifact goes in azure storage and the development system sends a response to the orchestrator. The last few lines of the log from the PDM system are mentioned below. The pipeline just does not move to the next stage and there are no errors in the logs as well. It keeps on displaying the Ongoing image continuously, the work item has no assignment and is not waiting for anything, the process pzWaitForNextEnvironment is not a part of the pyWorkpage.pxStageHistory and it seems does not get executed. Any thoughts where it might be going wrong ?

2019-03-05 12:56:22,570 [PegaRULES-Batch-2] [Rule_Obj_Activity.pzCreateTaskWrapper.Pega_Int_Pipeline.Action] INFO Task execution completed for task : publish
Posting status to release manager system. Status object:
{
"pxObjClass":"Pega-Int-Pipeline"
,"pyAccessGroup":"XXXXXXXXXXDev:Administrators"
,"pyApplicationName":"XXXXXXXXXXDev"
,"pyApplicationVersion":"19.01"
,"pyBuildArtifactName":"XXXXXXXXXXDev.zip"
,"pyCallBackURL":"https://***-*.apps.***.xyz.nl/prweb/PRRestService/cicd/v1/task/publish/status?FlowName=pzPublishRAP&FlowActionName=pzPauseTask"
,"pyDoPackage":"true"
,"pyFilePath":"devops/dev/XXXXXXXXXXDev/19.01/XXXXXXXXXXDev/xyz.zip"
,"pyID":"PEGA-PIPELINE-CD RB-36"
,"pyPipelineName":"XYZ"
,"pyProductName":"XXXXXXXXXXDev"
,"pyProductVersion":"19.01.04"
,"pyRepositoryName":"Azure Staging Repository"
,"pyStatusValue":"SUCCESS"
,"pySystemNodeID":"66ff6164d9bca262b1d07d97b7e109e0"
,"pyBuildArtifact":{
"pxObjClass":"Data-Artifact"
,"pySize":"3.1590869E7"
,"pyTargetLocation":"devops/dev/XXXXXXXXXXDev/19.01/XXXXXXXXXXDev/xyz.zip"
}
}

=============== End of remote server logs for task: publish, Server:Development ===============
2019-03-05 07:56:24,721 [Default user] [XYZ] [XXXXXXXXXXDev19.01] [RinoTest] INFO Remote task execution completed.
2019-03-05 07:56:24,789 [Default user] [XYZ] [XXXXXXXXXXDev19.01] [RinoTest] INFO Task Generating build got COMPLETED. Start time:2019-03-05 07:55:12, End time:2019-03-05 07:56:24, Time taken:1.20 mins

DevOps
Moderation Team has archived post
Share this page LinkedIn