Question

3
Replies
595
Views
Sudheer Nimmagadda (Sudheer Nimmagadda)
Highmark Health
Sr Application Developer
Highmark Health
US
Sudheer Nimmagadda Member since 2018 3 posts
Highmark Health
Posted: October 16, 2018
Last activity: October 26, 2018
Posted: 16 Oct 2018 16:29 EDT
Last activity: 26 Oct 2018 10:18 EDT
Closed
Solved

Does PEGA v6.2 sp2 supports TLS 1.1/1.2 ?

Hello,

I am getting below error while trying to execute Connect-rest rule in Pega v 6.2 sp 2.

"- javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated"

I ran below code in PEGA 6.2 sp2, it returned [TLSv1, TLSv1.1, TLSv1.2] . means Pega 6.2 sp2 supports TLS 1.1/1.2 ?

{
String[] prots = javax.net.ssl.SSLContext.getDefault().getSupportedSSLParameters().getProtocols();
myStepPage.putString(".pyNote", java.util.Arrays.toString(prots));
}
catch (Exception e)
{
oLog.error(e);
}

few article says - "Support for TLS started in PRPC 6.3 SP1 not in 6.2".so please clarify whether v6.2 SP2 supports TLS 1.X or not ?

Regards,

Sudheer Nimmagadda

Low-Code App Development Data Integration
Moderation Team has archived post, This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.