Question

7
Replies
1519
Views
imranullah Member since 2013 27 posts
Incessant Technologies
Posted: 4 years ago
Last activity: 4 years 1 month ago
Closed
Solved

Email Listener won't start

Hi Everyone, 

We are trying to create a email listener, but whenever the listener is starting we are getting the following error. 

com.pega.pegarules.pub.PRException: Email listener 'Listener.TestEmailListener' failed to connect to Email Server - The server indicated that the authentication credentials for this Email Account are incorrect.
From: (AA6478CC4243805F51FB67CE96C980D35:(Engine Startup Init Services)) 
    at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.setup(EmailListener.java:2096)
    at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.setup(EmailListener.java:1969)
    at com.pega.pegarules.integration.engine.internal.services.listener.ListenerWrapper.launchListener(ListenerWrapper.java:151)
    at com.pega.pegarules.integration.engine.internal.services.listener.ListenerStateManagerImpl.startOneListener(ListenerStateManagerImpl.java:752)
    at com.pega.pegarules.integration.engine.internal.services.listener.ListenerStateManagerImpl.startServiceTypeListeners(ListenerStateManagerImpl.java:492)
    at com.pega.pegarules.integration.engine.internal.services.listener.ListenerStateManagerImpl.startListenerType(ListenerStateManagerImpl.java:439)
    at com.pega.pegarules.integration.engine.internal.PRIntegrationEngineProviderImpl.initServices(PRIntegrationEngineProviderImpl.java:175)
    at com.pega.pegarules.session.internal.mgmt.PREnvironment.initServices(PREnvironment.java:644)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

We ensured that the credentials used for the server are correct.

We tried out the following by going through the solutions/suggestions that are available in PDN. 

https://pdn.pega.com/support-articles/we-are-getting-authentication-cre…

https://pdn.pega.com/support-articles/failed-test-connectivity-email-ac…

Also, Tried installing latest certificates on the JVM. 

Can anyone of you suggest some approaches to over this problem? Thanks! 

 

Case Management
Moderation Team has archived post
Share this page LinkedIn