Question

1
Replies
1619
Views
Trinanjan Dasgupta (TRINANJAN)
Cognizant Technology Solutions
Trinanjan Dasgupta
Cognizant Technology Solutions
IN
TRINANJAN Member since 2013 5 posts
Cognizant Technology Solutions
Posted: November 20, 2017
Last activity: November 22, 2017
Posted: 20 Nov 2017 17:08 EST
Last activity: 22 Nov 2017 0:50 EST
Closed

Error opening workobject- java.lang.NoClassDefFoundError: Could not initialize class com.pega.pegarules.integration.engine.internal.util.PRServiceUtilsPriv

Hi Team,

In our development environment, we are experiencing an issue that when we try to open any work object, we are unable to and are seeing the following error on screen-

Action that failed
For class:Data-Portal-Current operator:a123456
Object key:-Read/Write:true
Error message:java.lang.NoClassDefFoundError: Could not initialize class com.pega.pegarules.integration.engine.internal.util.PRServiceUtilsPriv
We are experiencing this in 2 Dev servers which have different code base which kind of tells us this may not be a code issue. So far, we have tried doing a complete clean restarts - which involved cleaning the Pega temp directories and also truncating the Database Cache tables. But the issue persists.
Would be really helpful if we can get any clue on this issue.
I have attached the complete error stacktrace from PegaRules log for your reference.
Thank you.
Regards,
Trinanjan Dasgupta
Enterprise Application Development Dev/Designer Studio Data Integration Java and Activities Case Management
Moderation Team has archived post, This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.