Question

6
Replies
2540
Views
Close popover
Shanmuganathan Gobinath (Gobi S)
EvonSys Europe BV
LSA
EvonSys Europe BV
NL
Gobi S Member since 2010 1 post
EvonSys Europe BV
Posted: August 4, 2016
Last activity: October 26, 2016
Closed

Getting empty values when referencing a property directly in Word Template

Hi All,

I am working on a requirement where I have to generate word document from a Word template.

I am trying to create Word Document using pzGenerateDocument RUF (as per solution mentioned in https://pdn.pega.com/community/pega-product-support/question/generate-word-document-using-word-document-which-can-show).

I am facing one problem, If I do a property reference for eg: {pega:reference .PropertyName} directly in the WordTemplate, I am not getting any value.

But If I refer same property inside the Corr rule then I can see the Value. (See the attachment)

Note: If I Refer a property inside a Corr rule and insert the corr in WordTemplate, I am able to see the value.

Property reference through {pega:insert corr=CorrName} is working

Direct properrty reference {pega:reference .PropertyName} is not working, returning empty value.

I also found this link https://pdn.pega.com/support-articles/word-merge-does-not-pull-pegareference-fields-template. Not sure this is the actual Root cause for my issue also.

Am I missing anything here? Need your Kind Help!!

Thanks in Advance

 ***Updated by Moderator: Lochan. Removed user added Ask the Expert and helpme tags. Apologies for confusion, shouldn't have been an end-user option; edited Category***

User Experience
Moderation Team has archived post,
Close popover This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.