Question

2
Replies
412
Views
karimullaD6391 Member since 2016 1 post
Aaseya IT Services Pvt. Ltd.
Posted: December 1, 2017
Last activity: January 5, 2018
Closed
Solved

Getting an Error while running the BIX Extract rule from putty

Hi All,

I am facing an Error while running the BIX Extract rule from putty.

BIX Issue Description:

Getting an Error while running the BIX Extract rule.(While running from Pega designer studio the extract rules are working fine and files are generating in App Server)

Steps Followed:

1. Migrated from PEGA 7.1.6 to PEGA 7.2.2 and also upgraded to BIX 7.2.2
2.All extract rules are migrated from 7.1.6 to Pega 7.2.2
3.Updated the Extract rule name in RunAllCM.sh file(it will run only one extract rule)
4.While running some of extract rules from the putty with command RunAllCM.sh getting an error like

Error: [ STANDARD] [ ] [ ] ( rd.resolve.SqlReportResolver) ERROR - An error occured during resolving the report definition - No access permission for the report.

5.This is not occurring for every extract rule. Its getting for some extract rules only( The Extract rules created in Data Classes)

Observations:

1. The Extract rules which are in work class those are running correctly and getting the results.

2 As we are getting the "No Access for the report Error" so thought that there would be an access issue for the data class and tried with Pega User DB credential by updating the prbootstrap.properties and prconfig.xml file. No Luck for this approach.

Please let us know your thoughts on this

***Edited by Moderator Marissa to update SR Details***

Low-Code App Development SR Exists
Moderation Team has archived post
Share this page LinkedIn