Question

1
Replies
60
Views
Maxime Leroux (MaximeL4)
Sopra Steria Group

Sopra Steria Group
FR
MaximeL4 Member since 2020 3 posts
Sopra Steria Group
Posted: August 6, 2020
Last activity: August 6, 2020
Posted: 6 Aug 2020 10:06 EDT
Last activity: 6 Aug 2020 19:14 EDT

Impossible to set set-max-map-count variable for pod pega-search

We deploy PEGA 8.3 on our private cloud.

Sometimes our peagasearch pods don't start. On log we can see

[2020-08-04T13:08:10,196][INFO ][o.e.b.BootstrapChecks ] [MWNgsmz] bound or publishing to a non-loopback address, enforcing bootstrap checks ERROR: [1] bootstrap checks failed [1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

For information we work on privileged access system that mean I can't modify the init container to change the value.

After reading the documentation I try to set-max-map-count directly on the pod with this command 


sysctl -w vm.max_map_count=262144

 https://www.elastic.co/guide/en/elasticsearch/reference/current/vm-max-map-count.html

but I have the error 

sysctl: setting key "vm.max_map_count": Read-only file system

How to modify this value?

The documentation https://community.pega.com/knowledgebase/articles/client-managed-cloud/cloud/meeting-requirements-and-prerequisites

We deploy PEGA 8.3 on our private cloud.

Sometimes our peagasearch pods don't start. On log we can see

[2020-08-04T13:08:10,196][INFO ][o.e.b.BootstrapChecks ] [MWNgsmz] bound or publishing to a non-loopback address, enforcing bootstrap checks ERROR: [1] bootstrap checks failed [1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

For information we work on privileged access system that mean I can't modify the init container to change the value.

After reading the documentation I try to set-max-map-count directly on the pod with this command 

sysctl -w vm.max_map_count=262144

 https://www.elastic.co/guide/en/elasticsearch/reference/current/vm-max-map-count.html

but I have the error 

sysctl: setting key "vm.max_map_count": Read-only file system

How to modify this value?

The documentation https://community.pega.com/knowledgebase/articles/client-managed-cloud/cloud/meeting-requirements-and-prerequisites

The Pega Platform search service uses Elasticsearch, which uses an mmapfs directory by default for 64-bit systems to store its indices (for more information, see the Elastic document, Virtual Memory. To increase the mmap count on your environment, do one of the following:

  • Update the vm.max_map_count setting in /etc/sysctl.conf on your nodes and set the value vm.max_map_count=262144.
  • Utilize the set-max-map-count initContainer in the example yaml file to automatically configure the setting. If you choose this method, note that the init container runs in privileged mode, so you must verify that your environment allows privileged containers.

 

 

Pega Customer Service 8.3 Case Management Technology Services Lead System Architect