Question

2
Replies
343
Views
Close popover
Arpita Dutta (ARPITA)
Accenture

Accenture
CN
ARPITA Member since 2011 7 posts
Accenture
Posted: January 18, 2019
Last activity: February 13, 2019
Closed

InfoForced logs not appearing in UAT.Log Level is set to Warn.Error logs are working fine.

Here is an extract of prlog4j.xml used to set level to WARN.
When I run a random test activity with Java->olog.infoIforced("MSG") or Log-Message with level infoForced-> No logs appear.
<Loggers>
<asyncRoot>
<AppenderRef ref="CONSOLE"/>
<AppenderRef ref="PEGA" level="WARN"/>
<AppenderRef ref="ALERT" level="ALERT"/>
<AppenderRef ref="ALERTSECURITY" level="ALERT"/>
</asyncRoot>
<Logger name="com.pega.pegarules.engine.context" additivity="false" level="WARN">
<AppenderRef ref="SECURITYEVENT"/>
</Logger>
<Logger name="com.pega.pegarules.session.internal.mgmt.SecurityEventLogger" additivity="false" level="WARN">
<AppenderRef ref="SECURITYEVENT"/>
</Logger>
<Logger name="com.pega.pegarules.data.internal.access.ExtractImpl" additivity="false" level="info">
<AppenderRef ref="BIX"/>
</Logger>
<Logger name="com.pega.pegarules.data.internal.access.ExtractParameters" additivity="false" level="info">
<AppenderRef ref="BIX"/>
</Logger>
<Logger name="com.pega.pegarules.data.internal.access.DatabaseUtilsCommonImpl" additivity="false" level="info">
<AppenderRef ref="BIX"/>
</Logger>
<Logger name="com.hazelcast" additivity="false" level="info">
<AppenderRef ref="CLUSTER"/>
</Logger>
***Edited by Moderator: Pallavi to update platform capability tags***
Pega Platform Data Integration Java and Activities
Moderation Team has archived post,
Close popover This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.