Question

1
Replies
73
Views
BrianR9472 Member since 2018 7 posts
Appriss
Posted: 1 year ago
Last activity: 1 year 7 months ago
Closed
Solved

Issue with static assembly utility

I have been working through getting the Static Assembly tool setup in our environment so we can pre-gen the files after a deployment. I see an issue in the logs when I run the tool that is preventing me from moving forward. We are using a split schema here, so in the prpcUtils.properties file I made sure to specify the schema names for both the Rules and Data schemas. For the JDBC username, we are using the database user that was setup at the time of the install (we call it datadev2). This user was setup at the time we installed Pega according to the installation instructions. Due to that, it defaults to the Data schema, but has given access to the Rules schema.

AlI that being said, I think I see where the issue is. I am receiving an ORA-00942: table or view does not exist error when the certain SQL statements run in the tool. Here is a snippet from the logs:

[java] Last SQL: SELECT distinct pr4_rule_vw.pyRuleName as "pyRuleName",(pr4_rule_vw.pxInsId) as "pxInsId",pr_index_reference.pxRuleFamilyName as "pxRuleFamilyName", pr_index_reference.pxRuleClassName as "pxRuleClassName",pr_index_reference.pxRuleObjClass as "pxRuleObjClass" FROM RULESDEV2.pr_index_reference INNER JOIN pr4_rule_vw ON (pr4_rule_vw.pxInsId = {fn concat('!', pr_index_reference.pxRuleFamilyName)} and pr_index_reference.pxRuleClassName is not NULL) or (pr4_rule_vw.pxInsId = pr_index_reference.pxRuleFamilyName and pr_index_reference.pxruleclassname is NULL) WHERE pr_index_reference.pxRuleObjClass not in('Rule-Method' ,'Rule-Obj-FieldValue', 'Rule-Obj-Class','Rule-File-Binary','Rule-File-Bundle','Rule-File-Text','Rule-Message','Rule-Connect-SOAP','Rule-Utility-Library','Rule-Utility-Function','Rule-Obj-Ticket','Rule-Access-Privilege') and pr_index_reference.pxInsIndexedKey = 'RULE-OBJ-ACTIVITY RULE-FILE-BINARY RETRIEVECHECKEDOUTRULEFILEBINARY #20131212T171428.609 GMT' and pr_index_reference.pxIndexPurpose = 'RuleReference' and pr_index_reference.pxObjClass = 'Index-Reference'

The issue is that PR4_Rule_VW is not prefixed with the Rules schema I defined. My assumption would be that it would be using since it appears that other database objects in the SQL are (pr_index_reference for example).

I would appreciate any insight that anyone can provide.

Regards,

Brian

***Edited by Moderator Marissa to update platform capability tags****

Pega Platform System Administration
Moderation Team has archived post
Share this page LinkedIn