Question

4
Replies
1528
Views
Close popover
Gopalakrishnan Krishnanand (Gopal@FT)
Franklin Templeton
Sr Software Engineer
Franklin Templeton
US
Gopal@FT Member since 2008 4 posts
Franklin Templeton
Posted: September 6, 2018
Last activity: October 1, 2018
Closed

Latest Java version supported?

Now that Oracle is releasing a new Java version every 6 months, how do we know which Java version we can upgrade to? Is there a policy to periodically support newer Java versions on PRPC 7.1.X and 7.2.X now that there will be frequent Java version releases?

We are using PRPC 7.1.9 (Java 7 - 1.7.0_79) and PRPC 7.2.2 (Java 8 - 1.8.0_u131). In the latest platform support guide I don't see any support beyond Java 8.

Excerpt from the support guide:

"Pega Platform requires the use of the Java 7 or Java 8 specification (depending upon the version
of Pega Platform, as shown in the charts above). Each of the Java vendors will routinely issue
maintenance that addresses security, performance, and stability issues in the JDK.
Pegasystems recommends that this maintenance be applied on a periodic basis; customers’
JDKs should never be more than a year behind current JDK maintenance levels."

Thanks

Gopal

***Edited by Moderator Marissa to update platform capability tags****

Data Integration Java and Activities
Moderation Team has archived post