Question

2
Replies
121
Views
JorgeR10 Member since 2014 8 posts
Cognizant
Posted: January 21, 2019
Last activity: January 28, 2019
Closed

Launch Robot from click on a Portal Button

Hello,

I have 3 doubts related with a Robot that I created on Robotics Studio:

1. I want to launch this Robot on click of a button that I have on the user Portal (Customer Service for Insurance Portal).

I created a Flow, with a Flow Action which launches the Robot on post-processing. If I simply Run the Flow (Actions -> Run, on the rule itself), it works fine. But if I try from the button (included Action "Flow in modal dialog" on click), it loads the Flow Action, but it does not launch the Robot when I Submit the form.

Any idea why?

2. I would like to know if there is some other way to invoke the Robot from Pega, other than the Flow Action, which is quite limited. In my case, there is no Case running necessarily, since I simply want to launch it from the Portal... but it seems that this scenario is not covered.

3. How can I pass a parameter to the Robot? I read about the Studio being able to access different properties present on the class that we define on the Robot Activity, but what if the field that I need to pass to the Studio is on a different class?, or maybe inside a structure like .Contact.PhoneNumber? Is there a way to send that field to the Studio?

Thank you.

Low-Code App Development User Interface Robotic Process Automation
Moderation Team has archived post
Share this page LinkedIn