Question

7
Replies
1438
Views
VivekSasidharan_13 Member since 2016 2 posts
Aegis Insurance
Posted: May 23, 2016
Last activity: July 1, 2016
Closed

Modal Dialog NOT working

We are currently migrating our application from V 6.2 to 7.1.5.

We are having an issue with Modal dialog.

In 6.2 a Local Action is setup to be launched from a Navigation Menu. Works fine in 6.2. But the same setup do NOT work in 7.1.5. in 7.1.5 ,on Clicking the Menu item, nothing happens. Modal Dialog do NOT open.

 

On tracing the issue in 6.2 and 7 , the difference is that in 6.2 pzPerformGridAction activity is getting triggered – which does NOT happen in 7.

OOTB Flow Actions as Modal Dialog are working BUT ONLY if the Flow Action is defined under @baseclass OR in the same class as the Navigation rule is defined.

 

I tried the following 

  1. Created a New Flow Action in @baseclass – New Flow Action comes up as  Modal Dialog as expected
  2. Created a New Flow Action in Assign-Worklist – New Flow Action comes up as  Modal Dialog as expected ( Assign-Worklist in this class where the Diary Navigation rule is defined )

  

 

If we want to use a Flow Action from any other class, we need to provide the Using Page parameter.  None of the Flow Actions are coming up as Modal Dialog if we use this parameter. Not even the OOTB Flow Actions works if we use this parameter. ( Tried with PegaApp-Work- • AppUpdateBusinessDetails ).

 

If I explicitly specify Using Page as Assign-Worklist in the Test 2 above, then even Test 2 fails.

 

So this seems to be a product issue in V7 – specifically when using the Using Page parameter.

Can anyone please confirm if this is an actual product issue in V7 ?

 

Low-Code App Development Upgrades User Interface
Moderation Team has archived post
Share this page LinkedIn