Question

6
Replies
417
Views
LEELAMOHAN Member since 2013 14 posts
Cts
Posted: 2 years ago
Last activity: 2 years ago
Closed
Solved

Not able to access SMA after upgrade to 7.4

Hello,

We had Pega 7.2 running on weblogic with JDK 1.7. Now we have upgraded it to Pega 7.4 after setting correct JAVA_HOME pointing to Java 1.8. Now we see an error while launching SMA. Below the error.

The error is that DosplayNodes.jsp is using java.util.Arrays class which cannot be resolved. I am very sure that JDK is corrptud or collision happenning between JDK 1.7 and JDK 1.8. I have set JAVA_HOME at nodemanager level as well as setDomainEnv.sh. Any help is highly appreciated. Thanks. Also screenshot attached,

weblogic.servlet.jsp.CompilationException: Failed to compile JSP /jsp/services2/DisplayNodes.jsp DisplayNodes.jsp:80:41: The type java.util.Map$Entry cannot be resolved. It is indirectly referenced from required .class files <%@page contentType="text/html" import="com.pega.jmx.connection.managenodes.NodeManager,java.net.URLEncoder,java.util.TreeMap,java.util.Hashtable,java.util.Iterator,javax.management.ObjectName,com.pega.jmx.connection.managenodes.Node" ^-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------^ DisplayNodes.jsp:159:15: java.util.Arrays cannot be resolved to a type java.util.Arrays.sort(nodes); ^-------------^

Low-Code App Development Upgrades
Moderation Team has archived post
Share this page LinkedIn