Question

4
Replies
1464
Views
Terrance Krolak (TJKROLAK)
Unitedhealth Group, Inc.
Architect
Unitedhealth Group, Inc.
US
TJKROLAK Member since 2011 6 posts
Unitedhealth Group, Inc.
Posted: May 9, 2018
Last activity: May 17, 2018
Posted: 9 May 2018 16:06 EDT
Last activity: 17 May 2018 4:58 EDT
Closed

OAuth 2.0 Client Registration

I have setup an OAUTH 2.0 Client Registration

I have setup SOAPUI and am attempting to "get the access token" from Pega but it is failing. Following errors in SOAPUI:

  • Wed May 09 14:55:54 CDT 2018:DEBUG:Attempt 1 to execute request
  • Wed May 09 14:55:54 CDT 2018:DEBUG:Sending request: POST /prweb/PRRestService/oauth2/v1/token HTTP/1.1
  • Wed May 09 14:55:54 CDT 2018:DEBUG:Receiving response: HTTP/1.1 403 Forbidden
  • Wed May 09 14:55:54 CDT 2018:DEBUG:Connection can be kept alive for 30000 MILLISECONDS
  • Wed May 09 14:55:54 CDT 2018:ERROR:An error occurred [OAuthProblemException{error='invalid_request', description='Missing parameters: access_token', uri='null', state='null', scope='null', redirectUri='null', responseStatus=0, parameters={}}], see error log for details
  • Wed May 09 14:55:54 CDT 2018:ERROR:An error occurred [org.apache.oltu.oauth2.common.exception.OAuthSystemException: OAuthProblemException{error='invalid_request', description='Missing parameters: access_token', uri='null', state='null', scope='null', redirectUri='null', responseStatus=0, parameters={}}], see error log for details
  • Wed May 09 14:56:25 CDT 2018:DEBUG:Connection closed

I see nothing in the Pega logs.

Data Integration
Moderation Team has archived post, This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.