Question

1
Replies
97
Views
BhupeshJ7652 Member since 2019 3 posts
Nationwide Building Society
Posted: 1 year ago
Last activity: 1 year 5 months ago
Closed

Openspan Services not running intermittent issues

Hi Team,

There is one RPA application of ours written in Openspan version 7.1, this application targets to launch another application (ex: Test.exe), on click of one button given in UI form.

This application was running fine since 5-6 months, but now we are facing one issue while launching test.exe application on button click. This test.exe is a separate desktop application that internally connects with web service to fetch some data.

We have investigated through logs that while clicking on button to launch test.exe below exception is getting logged:

Exception logged in DB below (using SQL to log exceptions):

->Exception Type: OpenSpan.Common.Memory.SharedMemoryInitializationException

Message : Unable to open private shared memory. Verify that service 'OpenSpan Services' is running

Time Stamp : 03/04/2019 09:27:38

Source : OpenSpan.Common

Method : Void .ctor()

Machine Name:

AUTOMATIONSTEP EXECUTIONSTATUSCODE EXECUTIONSTATUSCODEDESCRIPTION

RAEUCAE000004:Starting Test 0 ->Exception Type: OpenSpan.Common.Memory.SharedMemoryInitializationException

Message : Unable to open private shared memory. Verify that service 'OpenSpan Services' is running

Time Stamp : 02/04/2019 10:05:44

Source : OpenSpan.Common

Method : Void .ctor()

Machine Name:

As per the message we have seen that Openspan service is getting stopped. Restarting the same also not working as its coming again and again. Can this be related to machine configuration (RAM, CPU Usage etc) as well?

Can you please help that why is it coming to all the systems intermittently even after starting the 'Openspan Services' service manually, or please share any workaround which can be implemented here?

Thanks and Regards

Bhupesh

Low-Code App Development Robotic Process Automation
Moderation Team has archived post
Share this page LinkedIn