Question

2
Replies
35
Views
PravallikaM465 Member since 2016 53 posts
Accenture Solutions Pvt Ltd
Posted: 2 years ago
Last activity: 2 years 5 months ago
Closed
Solved

Outlook Application Getting Locked By OpenSpan Solution During Runtime

Hi,

I have developed an OpenSpan Solution contains Single Project Using Outlook Connector, Solution gets triggered on NewMail Event of Outlook Connector When ever new email comes (there are filters applied to work only for particular email E.g; it works only For Forwarded Emails which has Subject as FW: & has only one .xls or .xlsx attachment & then perform the business operation & reply to the same email ),while testing the Solution in Studio I tried to test for exceptions by Sending Email (with Subject FW: & more than one attachments ) where it is supposed to catch the exception (Defined in Automation )) & send an email (using Outlook) to Some email recipients (here am testing to send it to my id ),usually for other exceptions occurred in between & if Automation is working fine also it is supposed to send email & Outlook gets updated with new emails, but when the exception occurred for email with more than 1 attachments it should Send Email & Exit the automation, but am unable to receive the email during runtime as Outlook is getting locked by runtime & am unable to access the Outlook & when I stop Debugging then only a able to receive the exception mails send by OpenSpan Solution,but when automation is run successfully without any exceptions then Solution is accessing & locking only when to read& Reply to Emails, once it is done it releases lock during runtime & am able to see new emails & reply emails sent by the Solution (when tested ).Is there any solution for to release lock when Exceptions occur in Solution.

Regards,

Pravallika.

Robotic Process Automation
Moderation Team has archived post
Share this page LinkedIn