Question

3
Replies
116
Views
FrédéricG Member since 2017 4 posts
Capgemini
Posted: 2 years ago
Last activity: 2 years 6 months ago
Closed

pljava provided for Pega 7.2.2 + Postgresql 9.5 requires centos 7+

Hi,

The pljava.so provided by Pega 7.2.2 (for Postgresql 9.5) requires libC v2.14, but centos 6 provides only 2.12.

# ldd pljava.so

-> /usr/pgsql-9.5/lib/pljava.so: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/pgsql-9.5/lib/pljava.so)

As libC can not be upgraded (bound to the OS), could you provide a pljava library which is compliant with centos 6.9 / libc v2.12 ?

And btw, which version of pljava is provided by Pega 7.2.2 ? That would help me as well to know it, but I did not find a way to guess.

Because my final concern is actually to upgrade my existing setup from Postgresql 9.3 to Postgresql 9.5, which seems to be a long shot from what I saw about pljava ...

Thanks !

Low-Code App Development Installation and Deployment
Moderation Team has archived post
Share this page LinkedIn