Question

6
Replies
285
Views
MichaelF1903 Member since 2012 26 posts
CYBG
Posted: August 17, 2017
Last activity: September 14, 2017
Closed

prbootstrap.properties finds wrong version of code?

We're attempting to update PRPC from 7.2.1 to 7.2.2. When we run the update.bat script, we get the following error:

[java] SEVERE:
[java] Aug 17, 2017 1:27:47 PM com.pega.pegarules.internal.bootstrap.PRMiniLoader
[java] SEVERE: ============================= Failed to bootstrap PegaRULES =============================
[java] Aug 17, 2017 1:27:47 PM com.pega.pegarules.internal.bootstrap.PRMiniLoader
[java] SEVERE:
[java] Aug 17, 2017 1:27:47 PM com.pega.pegarules.internal.bootstrap.PRMiniLoader
[java] SEVERE: Could not load the java class 'com/pega/pegarules/internal/bootstrap/phase2/PRBootstrapImpl.class' from the database table 'PRWFNPE1.pr_engineclasses'
[java] Aug 17, 2017 1:27:47 PM com.pega.pegarules.internal.bootstrap.PRMiniLoader
[java] SEVERE: This is usually due to an empty 'PRWFNPE1.pr_engineclasses' table, or possibly it does not contain the configured codeset version.
[java] Aug 17, 2017 1:27:47 PM com.pega.pegarules.internal.bootstrap.PRMiniLoader
[java] SEVERE: In this run the prbootstrap.properties specified 'pega-enginecode:07-10-27', checking database...
[java] Aug 17, 2017 1:27:47 PM com.pega.pegarules.internal.bootstrap.PRMiniLoader

...

[java] ============ PegaRULES Bootstrap Configuration ============
[java] Date: Thu Aug 17 13:27:47 BST 2017
[java] Java Version: Oracle Corporation 1.8.0_60
[java] Configuration: file:/C:/Users/S514812/AppData/Local/Temp/PegaInstallTemp-15-August-2017-14.00.26/prbootstrap.properties
[java] Pega-EngineCode: 07-10-27
[java] JDBC Driver: oracle.jdbc.OracleDriver
[java] JDBC URL: jdbc:oracle:thin:@vrhogdu100.eu.nag.net:1643/PWFU.eu.nag.net
[java] JDBC User: PWFU_SYS
[java] Database: Oracle Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production
[java] With the Partitioning, OLAP, Data Mining and Real Application Testing options
[java] Driver: Oracle JDBC driver 11.2.0.2.0
[java]
[java] (!) Unable to use given database configuration
[java] (!) Unable to locate classes on filesystem
[java] =============== End Bootstrap Configuration ===============

The pzCodesetVersion for the prbootstrap.properties record in the pr_engineclasses table is 07-10-25, which I assume is correct for the version of 7.2.1 that we have installed. So why does the 7.2.2 update expect it to be 07-10-27 and throw a fit because it's not (assuming that what the above means)?

We've attempted five PRPC updates in the past few years, and only one was successful. In all other cases we had to export the code in a product file, wipe and install the new version and then import the application. Has this been the experience of any other PRPC users? Is there really an easy way to update PRPC or is the complete wipe-and-reinstall the only way to be sure?

Low-Code App Development Upgrades
Moderation Team has archived post
Share this page LinkedIn