Question

2
Replies
738
Views
GuilhermeV7620 Member since 2016 18 posts
Capgemini
Posted: March 6, 2018
Last activity: March 9, 2018
Closed

Problem with refresh screen - net::ERR_CONNECTION_RESET

I have encountered a problem in an application in the project that I participate in, when accessing through a custom Servlet. However, this problem does not happen for all environments.

In the application we have a step where a screen is presented, where the user must select one of the options. When performing this action, the screen is updated, presented according to the selected option, the additional items. This behavior works very well in the development environment and the above environment that is used for testing. However when we are going to use the homologation environment, when doing the same action, the screen is not updated and using the Google Chrome debugger, I can identify the following error messages:

pzevalharnessjson_12057459600.js!pzpega_ui_lib_provider_1191955478!pega_yui_13894285352!desktopwrapper_13771276436!pzautomationscripts_1856294521!pzpega_portal_13217230007!pzpega_ui_jquery_1793248835!pega_ui_harness_145293630!pzpega_ui_messaging_1802554968!pzpega_ui_jstree_1221119030!pzpega_ui_inspector_bundle_11887904729!pzpega_feedback_crawl_11445778958.js!pzpega_feedback_13882713703.js!!.js:718 WebSocket connection to 'ws://127.0.0.1/prweb/PRPushServlet/!@7de6df400b4532e41f0f0a8fa348185a!?PZSRVRPSH=true&portalName=BradescoPortal&X-Atmosphere-tracking-id=0&X-Atmosphere-Framework=2.3.1-javascript&X-Atmosphere-Transport=websocket&X-Atmosphere-TrackMessageSize=true&Content-Type=application/json&X-atmo-protocol=true' failed: Error during WebSocket handshake: Unexpected response code: 501
AV @ pzevalharnessjson_12057459600.js!pzpega_ui_lib_provider_1191955478!pega_yui_13894285352!desktopwrapper_13771276436!pzautomationscripts_1856294521!pzpega_portal_13217230007!pzpega_ui_jquery_1793248835!pega_ui_harness_145293630!pzpega_ui_messaging_1802554968!pzpega_ui_jstree_1221119030!pzpega_ui_inspector_bundle_11887904729!pzpega_feedback_crawl_11445778958.js!pzpega_feedback_13882713703.js!!.js:718

pzevalharnessjson_12057459600.js!pzpega_ui_lib_provider_1191955478!pega_yui_13894285352!desktopwrapper_13771276436!pzautomationscripts_1856294521!pzpega_ui_jquery_1793248835!pega_ui_harness_145293630!pzpega_ui_messaging_1802554968!pzpega_ui_jstree_1221119030!pzpega_ui_inspector_bundle_11887904729!pzpega_feedback_crawl_11445778958.js!pzpega_feedback_13882713703.js!!.js:6 POST http://127.0.0.1/prweb/SSOServlet/7RyR0YrW6Qf7xHXw7ncG6fRDk9o6jdEH*/!PS1__TABTHREAD3?pyActivity=pzPerformGridAction&pzTransactionId=2e8eac347b16fb515e6696806e863948&pzFromFrame=&pzPrimaryPageName=pyWorkPage&ThreadName=&EditConfig=harness&noThreadProcess=true&rowPage=pyWorkPage.RuleFormData.ProductOptions(1)&Location=pyActivity%3DpzPrepareAssignment%26NewTaskStatus%3DConfigureOptions%26TaskIndex%3D%26StreamType%3D%26FieldError%3D%26FormError%3DNONE%26pyCustomError%3DBradescoErrors%26bExcludeLegacyJS%3Dtrue%26ModalSection%3DpzGridEmbedPaneTemplate%26modalStyle%3D%26PrevDisabled%3Dtrue%26rowPage%3DpyWorkPage.RuleFormData.ProductOptions(1)%26modelessDialog%3Dtrue%26pyPropRef%3DpyWorkPage.RuleFormData.ProductOptions(1)%26pzHarnessID%3DHIDC53C07C3A2FB5B0D9344329737CB7EDA%26activeGridObj%3D%5Bobject%20Object%5D%26bRODetails%3Dtrue%26KeepMessages%3Dfalse%26TopLevelPageErrors%3Dfalse%26UITemplatingStatus%3DN%26BaseReference%3DpyWorkPage.RuleFormData%26isModalFlowAction%3Dtrue%26bIsModal%3Dtrue%26bIsOverlay%3Dfalse%26StreamClass%3DRule-HTML-Section%26ActionSection%3DpzGridEmbedPaneTemplate%26GridAction%3Dtrue%26BaseThread%3DPS1__TABTHREAD3&PagesToCopy=pyWorkPage&pzHarnessID=HIDC53C07C3A2FB5B0D9344329737CB7EDA&inStandardsMode=true&AJAXTrackID=2&HeaderButtonSectionName=SubSectionConfigurePlanDetailsBB&ClientInt=Start net::ERR_CONNECTION_RESET

The application runs on a WebSphere 8.5 server installed on ZOS

Has anyone ever been through this situation or do you have any idea what we can apply?

***Edited by Moderator, Maryrita: moved to Product Support from Applications***

Low-Code App Development Low-Code App Development Testing Applications System Administration
Moderation Team has archived post
Share this page LinkedIn