Question

7
Replies
1834
Views
X
VartikaA Member since 2015 6 posts
Sopra Steria India
Posted: 2 years ago
Last activity: 2 years 3 months ago
Closed

The process CRM.exe failed to start within the given timeframe. Continue waiting?

Hello,

I have recently started my training on Pega Robotics and I am facing a very common issue faced by all “The process CRM.exe failed to start within the given timeframe. Continue waiting?”, but the posts on PDN did not resolve it for me. (or maybe there is another post which I did not come across yet)

My problem in detail below -

1. I completed my Interrogation of the CRM application as specified in the exercise.

2. I shut down my system and the next day I opened my .ossln file in Pega Robotics Studio. Then I added the automation and when I started debugging it --> it gave me the very common error which is supposedly said to be resolved by the later version of Pega Robotics Studio, but it does not works for me as the version I have is PEGA_RAS_8_0_1076 (that is higher) and also since I was able to interrogate the previous day. Here is the error - "The process calc.exe failed to start within the given timeframe. Continue waiting?" [P.S. : I cannot even interrogate now]

3. I tried couple of things like turning off the Output Publisher as off as mentioned in various articles (for example - https://pdn.pega.com/community/product-support/question/unable-start-pr…).

4. I could not find BrowserBitness property so I could not try that solution.

5. As I continued my investigations, I tried to get something in logs, and as mentioned in various articles, I checked my %APPDATA% logs, but did not find RuntimeLog.txt. But I found StudioLog.txt, in which I found the following -

Info | 12:22:52.459 PM | 1 | STA | Designer | | | Deserialized 'D:\Profiles\varora\Documents\Pega Robotics Studio\Projects\TrainingCertification\CRMAdapter\CRM.os' in 1.63 seconds
Info | 12:22:52.940 PM | 1 | STA | Shell | CRM | | Designer created and initialized for 'D:\Profiles\varora\Documents\Pega Robotics Studio\Projects\TrainingCertification\CRMAdapter\CRM.os'
Info | 12:22:54.804 PM | 11 | MTA | Windows Adapter | CRM | | Starting adapter
Verbose | 12:22:54.826 PM | 11 | MTA | UI Connectors | | | ExpressTranslatorService.EnsureTranslatorsLoaded() - ENTER
Info | 12:22:54.833 PM | 11 | MTA | UI Connectors | | | ExpressTranslatorService.EnsureTranslatorsLoaded() - Translators are not loaded. Process project types.
Info | 12:22:56.103 PM | 11 | MTA | Adapter Reparenting | CRM | | WindowsAdapterBase.StartProcess: No user control has registered to reparent this adapter
Info | 12:22:56.118 PM | 11 | MTA | Windows Adapter | CRM | | Starting Process - Target: , Path: D:\OpenSpan\CRM Setup\CRM.exe, Dir: D:\OpenSpan\CRM Setup, Args: , Timeout: 10000
Info | 12:22:56.118 PM | 30 | STA | Windows Adapter | | | InvocationForm.OnHandleCreated: Found internal SetState2
Info | 12:22:56.134 PM | 30 | STA | Windows Adapter | | | InvocationForm.OnHandleCreated: Calling base...
Info | 12:22:56.134 PM | 30 | STA | Windows Adapter | | | InvocationForm.OnHandleCreated: Base called
Info | 12:22:56.306 PM | 11 | MTA | Windows Adapter | CRM | OpenSpan.Adapters.Windows.WindowsProcess-32459944 | WindowsProcess.InjectAndResumeProcess: Process D:\OpenSpan\CRM Setup\CRM.exe started, injected and resumed
Info | 12:31:03.597 PM | 24 | MTA | Windows Adapter | CRM | | Starting adapter
Verbose | 12:31:03.733 PM | 24 | MTA | UI Connectors | | | ExpressTranslatorService.EnsureTranslatorsLoaded() - ENTER
Info | 12:31:03.748 PM | 24 | MTA | Adapter Reparenting | CRM | | WindowsAdapterBase.StartProcess: No user control has registered to reparent this adapter
Info | 12:31:03.763 PM | 24 | MTA | Windows Adapter | CRM | | Starting Process - Target: , Path: D:\OpenSpan\CRM Setup\CRM.exe, Dir: D:\OpenSpan\CRM Setup, Args: , Timeout: 10000
Info | 12:31:03.773 PM | 45 | STA | Windows Adapter | | | InvocationForm.OnHandleCreated: Found internal SetState2
Info | 12:31:03.780 PM | 45 | STA | Windows Adapter | | | InvocationForm.OnHandleCreated: Calling base...
Info | 12:31:03.787 PM | 45 | STA | Windows Adapter | | | InvocationForm.OnHandleCreated: Base called
Info | 12:31:03.959 PM | 24 | MTA | Windows Adapter | CRM | OpenSpan.Adapters.Windows.WindowsProcess-11865849 | WindowsProcess.InjectAndResumeProcess: Process D:\OpenSpan\CRM Setup\CRM.exe started, injected and resumed

6. Tried to give permission on the folder where I have CRM.exe (thinking that there might be some read/write issue). But nothing works :(

7. I even tried to create a new project for Calculator application (Calc.exe) but still the same error.

Now my questions are as follows -

1. Is there any way to resolve the error "The process calc.exe failed to start within the given timeframe. Continue waiting?"? I am for the moment clueless on this, and I only option I see is to uninstall and then install it again. But I would prefer to debug it once before to do the simplest solution.

2. Is there any other log I should check? How can I get the RuntimeLog.txt?

3. Are there any useful links on this subject which could help in understanding the subject in detail?

4. Also I see another error; which is "OS_EVTLOG not found". Is it an issue?

Waiting eagerly for a positive response on the same.

Thanks & Regards,

Vartika

***Updated by moderator: Lochan to move post from PSC to Pega Academy***

Robotic Process Automation Pega Academy
Moderation Team has archived post
Share this page LinkedIn