Question

13
Replies
278
Views
khuls Member since 2013 4 posts
PEGA
Posted: 3 years ago
Last activity: 3 years 1 month ago
Closed
Solved

Product file having only Database Rule is not getting imported.

Pre-requisites

=================

  1. Stop Application Server
  2. Create schema
    1. psql -U postgres -d pega -c "CREATE ROLE externalmktdata LOGIN PASSWORD 'externalmktdata' NOSUPERUSER INHERIT CREATEDB CREATEROLE NOREPLICATION;"
    2. psql -U postgres -d pega -c "CREATE SCHEMA externalmktdata AUTHORIZATION pega;"
    3. psql -U postgres -d pega -c "GRANT ALL ON SCHEMA externalmktdata TO pega;"
    4. psql -U postgres -d pega -c "GRANT ALL ON SCHEMA externalmktdata TO externalmktdata;"
    5. psql -U postgres -d pega -c "ALTER ROLE ExternalMKTData SET search_path = externalmktdata, pegadata, public;"
  3. Add below line within pegarules tag /opt/tomcat/webapps/prweb/WEB-INF/classes/prconfig.xml
    1. <env name="database/drivers" value="/opt/tomcat/lib/postgresql.jar" />
    2. <env name="database/databases/ExternalMKTData/url" value="jdbc:postgresql://localhost:5432/pega" />
    3. <env name="database/databases/ExternalMKTData/userName" value="externalmktdata" />
    4. <env name="database/databases/ExternalMKTData/password" value="externalmktdata" />
    5. <env name="database/databases/ExternalMKTData/defaultSchema" value="externalmktdata" />
  4. Start Application Server.

Steps to reproduce

=================

  1. Login as Administrator@pega.com
  2. Create a Database rule with below details
    1. Name: ExternalMKTData
    2. How to connect: use configuration in preferences
    3. In Advance tab > List other database > Add PegaDATA
  3. Logout and Login using different user credentials.
  4. Create a Product rule having only Database Rule “ExternalMKTData”. Create product file and download it.
  5. Delete database rule “ExternalMKTData”.
  6. Logout and Login as Administrator@pega.com
  7. Import earlier downloaded product file

Observation

=================

Product file having only Database Rule is not getting imported.

There is no error in logs. But, one warning says “Database externalmktdata-tmp1493786976047 should be defined in the bootstrap preferences, but it is not there”.

***Updated by moderator: Lochan to add SR details***

System Administration SR Created
Moderation Team has archived post
Share this page LinkedIn