Question

1
Replies
486
Views
CM758284 Member since 2018 3 posts
Pegasystems Limited
Posted: 2 years ago
Last activity: 2 years ago
Closed

prweb is not being launched

We are upgrading from Pega 7.1.5 version to Pega 7.2.1 version. Following steps are executed -

1) executed generateddl.sh script
2) executed generated oracledate.sql and oracledate_udf.sql script to make db specific changes. All scripts are successfully executed.
3) After db script execution, I have executed update.sh script. That script is also executed successfully and displayed "Build Success" message in 1 second.
4) We have deleted existing prpc_wls_jee4.ear, prsysmgmt.war file from Weblogic AS
5) We have deployed new (version 7.21) prpc_wls_jee4.ear, prsysmgmt.war file in Weblogic AS
6) We have restarted the Weblogic AS
7) We have tried to launch the http://<host> :<port>/prweb/PRServlet - it shows the error message
8) We also tried to launch http://<host> :<port>/prsysmgmt - which was launched successfully, but didn't show any information due to "mBean" error.

While trying to launch prweb/PRServelet following exception is being thrown in weblogic log -

####<Aug 28, 2018 2:38:10 PM BST> <Emergency> <com.pega.pegarules.internal.bootstrap.PRBootstrap> <XXXX> <XXXX> <[ACTIVE] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <> <XXXX> <BEA-000000> <prbootstrap.properties merged with prbootstrap entries in Data-Admin-System-Settings>

####<Aug 28, 2018 2:38:10 PM BST> <Emergency> <com.pega.pegarules.internal.bootstrap.PRMiniLoader> <XXXX> <XXXX> <[ACTIVE] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <> <XXXX> <BEA-000000> <Will load phase 2 bootstrap from Pega-EngineCode:07-10-11>

####<Aug 28, 2018 2:38:10 PM BST> <Error> <com.pega.pegarules.boot.internal.extbridge.AppServerBridgeToPega> <XXXX> <XXXX> <[ACTIVE] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <> <1535463490279> <BEA-000000> <Problem during method invocation (init)

java.lang.NoClassDefFoundError: com/pega/pegarules/internal/bootstrap/BaseLogger

at com.pega.pegarules.internal.bootstrap.phase2.PRBootstrapImpl.<clinit>(PRBootstrapImpl.java:185)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

***Edited by Moderator Marissa to update SR Details***

Pega Platform SR Exists
Moderation Team has archived post
Share this page LinkedIn