Question

1
Replies
145
Views
KenKlatt Member since 2016 1 post
Perficient
Posted: 1 year ago
Last activity: 1 year 3 months ago
Closed

Robot cannot connect to local Pega DB

I am using the sqlquery component from the toolbox in an automation to query the pega database, but the connection fails when the robot processes a case.
The following exception shows in the Runtime_Log4Net:
Exception Type: System.Data.SqlClient.SqlException
Errors: ICollection (System.Data.SqlClient.SqlErrorCollection) with 1 items
System.Data.SqlClient.SqlError: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
ClientConnectionId: 00000000-0000-0000-0000-000000000000
Class: 20
LineNumber: 0
Number: 53
Procedure: NULL
Server: ""
State: 0
Source: ".Net SqlClient Data Provider"
ErrorCode: -2146232060
Message: "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"
Data: IDictionary (System.Collections.ListDictionaryInternal) with 5 items
HelpLink.ProdName: Microsoft SQL Server
HelpLink.EvtSrc: MSSQLServer
HelpLink.EvtID: 53
HelpLink.BaseHelpUrl: http://go.microsoft.com/fwlink
HelpLink.LinkId: 20476
TargetSite: Void .ctor(System.Data.ProviderBase.DbConnectionPoolIdentity, System.Data.SqlClient.SqlConnectionString, System.Data.SqlClient.SqlCredential, System.Object, System.String, System.Security.SecureString, Boolean, System.Data.SqlClient.SqlConnectionString, System.Data.SqlClient.SessionData, System.Data.ProviderBase.DbConnectionPool, System.String, Boolean)
HelpLink: NULL
HResult: -2146232060
Server OS is Windows Server 2012
Pega is running on server
Pega DB is hosted on server
Robot is loaded on Runtime running on the server
DSN is configured for database and connects successfully
If I open the solution in Studio running from the server, the SQLQuery component fails to connect. Error: Test connection failed because of an error in initializing provider. [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
If i open the solution in Studio from another computer and configure DSN to connect to the DB on the server instance, the connection is successful.
I will appreciate any help.
***Edited by Moderator Marissa to update platform capability tags****
Data Integration Robotic Process Automation
Moderation Team has archived post
Share this page LinkedIn