Question

1
Replies
219
Views
Close popover
Nilutpal Das (DASN0001)
Cognizant Technology Solutions

Cognizant Technology Solutions
IN
DASN0001 Member since 2007 8 posts
Cognizant Technology Solutions
Posted: March 1, 2019
Last activity: March 6, 2019
Closed

Robotics Deployment application is not found -OSD.exe

Hi,
I am getting an exception while executing an automation or build a solution. This is happening across all the solutions under the studio. I tried to clean up the solution but it didn't work. Here are the exception details that i am getting while running the automation from studio. I like to avoid re-installation; any help on this issue will be greatly appreciated.
Error in Studio -
Severity Code Description Project File Line
Error Deployment application is not found: C:\Program Files (x86)\OpenSpan\OpenSpan Studio for Microsoft Visual Studio 2015\OSD.exe VehicleEntry C:\xx\xx\xx\Pega Robotics Studio\Projects\AutoValueEstimator\VehicleEntry\VehicleEntry.osproj 1041

Error The "ProjectDeployment" task failed unexpectedly.
System.InvalidOperationException: Cannot start process because a file name has not been provided.
at System.Diagnostics.Process.Start()
at Microsoft.Build.Utilities.ToolTask.ExecuteTool(String pathToTool, String responseFileCommands, String commandLineCommands)
at Microsoft.Build.Utilities.ToolTask.Execute()
at OpenSpan.Build.Tasks.ProjectDeployment.Execute()
at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__26.MoveNext() VehicleEntry C:\xx\xx\xx\Pega Robotics Studio\Projects\AutoValueEstimator\VehicleEntry\VehicleEntry.osproj 1041
Exception From Log File
Diagnostic Info:
Diagnostic.MachineName: XXX-XXX
Diagnostic.FullName: OpenSpan, Version=8.0.0.0, Culture=neutral, PublicKeyToken=XX
Diagnostic.AppDomainName: DefaultDomain
Diagnostic.WindowsIdentity: DESKTOP-xxx\dnilu
Diagnostic.ApplicationName: OpenSpan.Studio.Shell
Exception Information
1) Exception Information
*********************************************
Exception Type: System.IO.FileNotFoundException
Message: "Could not load file or assembly 'OSD, Version=8.0.0.0, Culture=neutral, PublicKeyToken=xxx' or one of its dependencies. The system cannot find the file specified."
FileName: "OSD, Version=8.0.0.0, Culture=neutral, PublicKeyToken=xx"
FusionLog: "WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
"
Data: IDictionary (System.Collections.ListDictionaryInternal) with 0 items
TargetSite: System.Collections.Generic.IList`1[System.String] GetAllBuildReferences(System.String, System.String)
HelpLink: NULL
Source: "OpenSpan.Build.Tasks"
HResult: -2147024894

Robotic Process Automation
Moderation Team has archived post,
Close popover This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.