Question

2
Replies
292
Views
X
SoumitraD Member since 2013 3 posts
Altisource Portfolio Solutions
Posted: 8 months ago
Last activity: 7 months 2 weeks ago

RPA not sending back the Robot Activity CompletionStatus

We have 6 bots which fetches data from different sources for one case and these bots work sequentially. So if one the bot runs into an exception, sometimes the status is not getting updated at the PRPC end and the case will still be in the Robot Queue. PFB the error we found in the runtime log.

RPA - Sending case result. WorkItem.Name: 'ICMAFetch'
Error | 09:43:44.174 AM | 37 | MTA | Robotics | | |
RoboticsApiHelper.SendCaseResult - Send case result failed. Case completion status: 'Completed with errors'.
Error | 09:43:44.174 AM | 37 | MTA | Robotics | | |
Error requesting data from Pega. https://altsrc-alts-prod1.pegacloud.net/prweb/api/v1/assignments/ASSIGN…!
PZCREATEROBOTICASSIGNMENT?actionID=pyCompleteAutomation
Error | 09:43:44.174 AM | 37 | MTA | Robotics | | |
Code: BadRequest(400), Content: {
"pxObjClass":"Pega-API-CaseManagement-Assignment"
,"errors":[
{
"ID":"Pega_API_055"
,"message":"Validation messages found."
,
"pxObjClass":"Pega-API-Error"
,"ValidationMessages":[
{
"pxObjClass":"Pega-API-Error-ValidationMessage"
,"ValidationMessage":"Unable to unlock the cover"
}
]
}
]
}

It says a Pega API Error so what we need to do to release from the bot queue and how we can avoid it from RPA side? Please reply back as we are in UAT phase and will be releasing to Prod by next week.

***Moderator Edit-Vidyaranjan: Updated Platform Capability***

Robotic Process Automation
Share this page LinkedIn