Question

6
Replies
1272
Views
Close popover
Ranjithkumar Chinnaswamy (RanjithkumarC)
AIG

AIG
US
RanjithkumarC Member since 2013 20 posts
AIG
Posted: March 31, 2016
Last activity: April 1, 2016
Closed
Solved

Rules forms doesnt not open

Rules set version  or any application UI rules belong to app ruleset doesnt open.Just shows blank screen,

On tracing the rule open i see errror on openUI defaults activity

** Invalid expression or reference: No candidates found [possible function name, ruleset/version or number of parameter problem] for Rule-Utility-Function in ruleset list Lib(Pega-RULES:DateTime).CurrentDateTime()

Below error logged

2016-03-31 16:48:59,333 [ WebContainer : 6] [ Developer] [ MLRCORE:01.01.02] (eForm.Rule_Obj_Property.Stream) ERROR ftwdsdbg2g31.r1-core.r1.aig.net|XX.XX.XXX.XX RanjiMLR - Error in JSP execution com.pega.pegarules.pub.generator.UnresolvedAssemblyError: Invalid expression or reference: No candidates found [possible function name, ruleset/version or number of parameter problem] for Rule-Utility-Function in ruleset list <null> Lib(Pega-RULES:DateTime).CurrentDateTime() at

2016-03-31 16:41:45,296 [nectorThreadPool : 1] [ STANDARD] [ ] (internal.library.LibLibraryDef) ERROR - Library Pega-UIEngine.Harness has inconsistent Rule-Utility-Function key / implementation issues. These may be the result of merging the Function from another ruleset.

Planning to delete the pegrules marker file and restart the server ? Any other suggestion to resolve this error ?

User Experience
Moderation Team has archived post,
Close popover This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.