Question

5
Replies
1806
Views
Agneta Teuchler (AgnetaT2)
Tieto Sweden AB

Tieto Sweden AB
SE
AgnetaT2 Member since 2019 1 post
Tieto Sweden AB
Posted: June 25, 2019
Last activity: December 29, 2019
Posted: 25 Jun 2019 10:46 EDT
Last activity: 29 Dec 2019 18:09 EST
Closed

SAML authentication fails - how to trace?

Hi,

We're trying to setup SAML authentication for Pega 8.2 and so far we've managed to get the following working:

1. Using the Login URL displayed in the SAML 2.0 tab, we get redirected to the IDP
2. Login works fine in the IDP
3. When IDP redirects me to Pega again, I end up on the ordinary login page, where I am prompted with username and password. I haven't managed to see anything in the logs.

Can you help me on how to view the logs for this? Do I somehow need to activate ACS service in Pega or can I check that it's alive somehow? We have checked that the ACS address is the same in the IDP, but I don't get any error messages or anything so I don't know what's happening.

This is what is auto generated in the Service Provider settings:
Entity Identification:
http://<MyHostAddress>/prweb/sp/1561056963
Assertion Consumer Service (ACS)
http://<MyHostAddress>/prweb/PRRestService/WebSSO/SAML/v2/AssertionConsumerService

Regards
Niclas

Low-Code App Development Data Integration System Administration
Moderation Team has archived post, This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.