Question

6
Replies
605
Views
cherb Member since 2014 3 posts
PEGA
Posted: 3 years ago
Last activity: 2 years 6 months ago
Closed

Skin Changes are not reflecting at runtime in the end user portal.

Hi Team,

We've been upgraded from PRPC6.3 SP1 to Pega 7.1.7. After successful upgrade, Whatever the changes done in the skin rules are not reflecting in the portal at runtime. However, the same changes are reflected in the preview section of the skin.

Below are the different approaches we tried to find the root cause,

1) "save as" of the skin rule to new ruleset version

2) Revalidate and Save of the Rule-PortalSkin type instances

3) Clearing the browser cache

4) Referred "pyEndUser71" skin rule instead of our sikn and observed that the changes are REFLECTING IN PORTALS.

After doing the above steps, it is very clear that only application skins have the problem where as ootb skins does not have the problem.

We are thinking that the Skin generation and cache could be the problem of not reflecting the skin at runtime. Is our assumption correct ?, if yes, what are the different cache tables that needs to be truncated and Is it also required to remove Pega Temp directory ?

Please let us know further steps to investigate.

Thank you.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Low-Code App Development Upgrades
Moderation Team has archived post
Share this page LinkedIn