Question

2
Replies
3774
Views
AMITTUTUN Member since 2011 62 posts
JKTechnosoft
Posted: 4 years ago
Last activity: 3 years 1 month ago
Closed
Solved

SLA not working properly

Hi, I have an SLA. The assignment to which SLA has been added have two flow action. One is visible to the user and user can perform action. Another flow action is made invisible using when condition in security option. When the assignment reaches GOAL we need to advance flow passin g the invisible flow action as a parameter. Now I have two problems.

1) I am setting "Set to the value of Property" in the Calculate Service Level field and giving a DateTime property of pyWorkPage in GOAL. Then I am adding the SLA in an assignment. But whenever any work item enter that assignment it is throwing the below error.

cannot be null/empty. page: pyWorkPage. Details: Invalid value for aReference passed to com.pega.pegarules.data.internal.clipboard.ClipboardPageImpl.getString(String)

2) I changed the Calculate Service Level field to "Interval from when the assignment is ready" and gave x min GOAL. In action I selected Advance Flow and gave the flow action name which was invisible to user. This time there is no error when the work iteem enters the assignment. But the "advance flow" saction was not working and the item remains in the assignment. I am using optim istic locking and whever I am refreshing the assignment its giving the below error.

com.pega.pegarules.pub.PRAppRuntimeException: Caused by Unable to authorize flow action execution: <pzInsKey of the flow action>

Require some help to resolve this.

***Updated by Moderator: Lochan. Removed user added Ask the Expert tag. Apologies for confusion, shouldn't have been an end-user option***

Case Management
Moderation Team has archived post
Share this page LinkedIn