Question

2
Replies
501
Views
Benneal92 Member since 2017 3 posts
The Hartford
Posted: November 24, 2019
Last activity: December 3, 2019
Closed
Solved

Stream Service - JOINING_FAILED - Failed to bind

Hi all,

I am new to Pega 8 and have seen that I am getting some issues with Stream Service. We have a cluster (agent01, user01, and user02 for example) and we are using DSS to set the value of the ports.

  • prconfig/dsm/services/stream/pyport/default
  • prconfig/dsm/services/stream/pybrokerport/default
  • prconfig/dsm/services/stream/pykeeperport/default
  • prconfig/dsm/services/stream/pyjmxport/default

The problem is eventually when we restart the instances we get "ChannelException: Failed to bind to:ourHost:port" because the port is showing as already taken while before that it joined fine. Consequently stream service is then down.

Some conclusions I have made:

It seems that nodes are fighting for resources since they are all using the same DSS values for the ports. Also it seems like any node is attempting to auto join after a restart as opposed to just agent01.

Because of how everything is setup we are hoping to avoid creating unique prconfig.xml files if possible. I am aware we can set the ports there.

all of that to ask these questions:

  1. Is there an auto join feature or anyway of influencing that process?
  2. Is DSS the right/wrong approach when in a clustered environment?
  3. What influence will setting the (-DNodeType=Stream)have and any ramifications we need to be aware of?

Hoping for an eloquent solution to avoid prconfig but may not exist. Thanks in advance for assistance on this newbie question.

-Ben

***Edited by Moderator: Lochan to update platform capability tags***

Pega Customer Decision Hub Decision Management System Administration
Moderation Team has archived post
Share this page LinkedIn