Question

7
Replies
6024
Views
NIKITAKOZLOV Member since 2012 9 posts
LANIT JSC
Posted: 4 years ago
Last activity: 3 years 6 months ago
Closed
Solved

System not able to find Function in one of the environments (com.pega.pegarules.pub.generator.UnresolvedAssemblyError , InvalidExpression, No candidates found)

On production system (PRPC 7.1.8) we have some problem:

"com.pega.pegarules.pub.PRAppRuntimeException: The flow SendToCreditDepartment had a problem on step Integrator2 of: com.pega.pegarules.pub.generator.UnresolvedAssemblyError: ** 2001449583§EscapeSpecSymbols§PegaEL-InvalidExpression    No candidates found [possible function name, ruleset/version or number of parameter problem]     for Rule-Utility-Function in ruleset list <null> expected since isEditing is false ruleset = ECM-FileNetComponent library = FileNetComponent functionName = EscapeSpecSymbols parameters = [ Item: param.PackageName Pega type = text Java data type = String]    @(ECM-FileNetComponent:FileNetComponent).EscapeSpecSymbols(param.PackageName)
From: (B1208A77259A79BBE63E2E6FA8D46E96F) "

The error was cleared by performing a Revalidate and Save of the rule where the function was referenced.

Also, we were given an official response from Pegasystems, this is a bug in the engine, and they gave us a hotfix (HFix-25979) that we do not encounter this problem in the future.

This problem occurs accidentally and is uncertain.

Related links to this problem:

  1. https://pdn.pega.com/support-articles/unable-find-function-after-upgrade-pega-718
  2. https://pdn.pega.com/forums/system-operations/system-not-able-find-function-one-environments

Met you are such a problem? What helped you solve it?

System Administration
Moderation Team has archived post
Share this page LinkedIn