Question

2
Replies
28
Views
X

There is no 'Client Credential Provider' secure data store available.

Hello. I'm trying to test a Client Credential Provider I created, following the C# sample provided in the Robot Runtime 19.1.34 installation. I believe I've configured everything correctly in CredentialManagerConfig.xml and CommonConfig.xml, but when the RPA Service attempts to start work, I get the following in RpaService.log:

Info    | 03:55:37.845 PM | 1      | MTA   | Service                   | *** Initializing Service *** Info    | 03:55:37.861 PM | 1      | MTA   | Service                   | .NET 4.5 or higher framework is available. Web connections will support TLS 1.1 and TLS 1.2 protocol. Info    | 03:55:37.877 PM | 5      | MTA   | Service                   | Service starting... Debug   | 03:55:37.892 PM | 5      | MTA   | Service                   | Current time zone: Eastern Daylight Time Info    | 03:55:37.955 PM | 5      | MTA   | Service                   | Service Mode: Scheduled Info    | 03:55:37.955 PM | 5      | MTA   | Service                   | Runtime launch retry feature: enabled Info    | 03:55:38.189 PM | 5      | MTA   | Service                   | Service started. Debug   | 03:56:38.206 PM | 6      | MTA   | Service                   | Scheduled work processing Debug   | 03:56:38.206 PM | 6      | MTA   | Service                   | Scheduler is currently in scheduled time interval Info    | 03:56:38.221 PM | 6      | MTA   | Service                   | Discovered 'Protected DPL Data Store' secure data store. Info    | 03:56:38.221 PM | 6      | MTA   | Service                   | Discovered 'Protected CyberArk Data Store' secure data store. Info    | 03:56:38.237 PM | 6      | MTA   | Service                   | Discovered 'Protected Machine Data Store' secure data store. Info    | 03:56:38.237 PM | 6      | MTA   | Service                   | Discovered 'Protected User Data Store' secure data store. Debug   | 03:56:38.237 PM | 6      | MTA   | Service                   | Discovered 4 secure data stores. Info    | 03:56:38.252 PM | 6      | MTA   | Service                   | Selected 'Client Credential Provider' as default secure data store for Machine scope. Error   | 03:56:38.268 PM | 6      | MTA   | Service                   | There is no 'Client Credential Provider' secure data store available. Error   | 03:56:38.268 PM | 6      | MTA   | Service                   | Object reference not set to an instance of an object. System.NullReferenceException: Object reference not set to an instance of an object.    at Pega.RpaService.Common.CredentialHelper.ResolveStore(String entryName)    at Pega.RpaService.Common.CredentialHelper.GetCredentials(String entryName, String& domain, String& userName, String& password)    at Pega.RpaService.Service.RpaService.DoScheduleWork() Debug   | 03:56:38.284 PM | 6      | MTA   | Service                   | Scheduled work processing - done

 

I've attached CommonConfig and CredentialManagerConfig. What might I be getting wrong?

 

 

***Edited by Moderator Marissa to update SR Details***

Pega Robotic Process Automation 8.0 Robotic Process Automation Healthcare and Life Sciences Robotics System Architect SR Created