Question

3
Replies
371
Views
Kannan Manickam (KannanM3)
Idexx Laboratories

Idexx Laboratories
US
KannanM3 Member since 2019 21 posts
Idexx Laboratories
Posted: December 11, 2019
Last activity: December 12, 2019
Posted: 11 Dec 2019 17:52 EST
Last activity: 12 Dec 2019 10:31 EST
Closed

Tracer on Service REST dont show any trace

I have a service REST and when I try to trace the service calls to see the logs and debug, the tracer works on a general scale but it doesnt show any trace many times and I have to either restart the tracer, refresh the browser, log off and log back in. I have to try multiple combinations of this and it will work sometime and doesnt at times. This is so frustrating while trying to develop the application.




Steps to Reproduce

Environment 1:


1. Open the tracer for 1st service REST and post a call, the tracer will show logs.

I have a service REST and when I try to trace the service calls to see the logs and debug, the tracer works on a general scale but it doesnt show any trace many times and I have to either restart the tracer, refresh the browser, log off and log back in. I have to try multiple combinations of this and it will work sometime and doesnt at times. This is so frustrating while trying to develop the application.

Steps to Reproduce

Environment 1:

1. Open the tracer for 1st service REST and post a call, the tracer will show logs.

2. Close the tracer, now open the tracer for the 2nd service REST and post a call, the tracer will show logs

3. Close the tracer and open the tracer for 1st service REST again and post a call, now no trace logs will be there

4. Close the tracer and open tracer for 2nd service rest again and post a call, now no trace logs will be there

Environment 2:

1. Open the tracer for an service REST and post a call, the tracer will show logs.

2. Change something in the service REST, save it

3. Close the tracer and reopen it, post a call now no trace logs will be there. This may not happen immediately but happens at one point suddenly so cant gaurantee that it would happen on the first save and reopen of the tracer.

Error Message

No error message just an empty tracer

Attempted Solutions

restart the tracer

refresh the browser

log off and log back in

wait for some time

Any combination of the above sometime helps

Low-Code App Development Data Integration
Moderation Team has archived post, This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.