Question

4
Replies
388
Views
FranciscoJavierG2301 Member since 2017 21 posts
Rulesware LLC
Posted: April 26, 2018
Last activity: November 6, 2018
Closed
Solved

Unable to connect Visual Studio to Robot Manager - Proposed solution is not working

Cannot comunicate the Pega Robocit Automation Studio withe a Robot Manager. I am getting following error message testing connectivity:

"Server Rejected Credential. You are no longer Authenticated"

The steps for testing the connectivity are:

1.- Open Tools
2.- Click on Options
3.- Expand Pega Robotics
4.- Click on Server Connectivity.
5.- Configure the connection using a RuntimeUser based on the Banker Por RuntimeUser as defined in the article https://pdn.pega.com/support-articles/unable-connect-visual-studio-robot-manager

Versions
Robot Manager is version 4
Pega Platform is 7.3.1
Pega Robot Automation Studio (PRAS) is version 8.0.1085.0

Other considerations:
1.- It is possible to download the "Relevant Properties" of the Pega Class at PRAS.
2.- The service packages for Robotic and for Pega API has the "Force SSL/TLS connection" disabled to be able to access the services by port 80, as CA signed certified is not available as we are in POC phase.
3.- Testing to invoke Pega API was performed using the RuntimeUser from Soap UI was successful
4.- The connection was tested with two applications, the Banker Pro application and with another application that includes Robot Manager.
5.- CommonConfig.xml is configured to enable Remote Manager. Studio and RuntimeConfig Files are configured to target same Pega Server where the applications with Robot Manager exist.

Robotic Process Automation
Moderation Team has archived post
Share this page LinkedIn