Question

3
Replies
808
Views
hemanthj Member since 2015 14 posts
Cognizant Technology Solutions
Posted: 4 years ago
Last activity: 4 years ago
Closed

Unable to create an application on Pega Rules or Pega DM Sample or DMSample

Please help us in resolving the following issue in the Pega 7.1.9 Sandbox.

 

Issue : Unable to create a new application.

 

Error message :

  1. For Case Creation Portal : Issue in Perform Harness.
  2. For Case Worker and Case Manager portal : Please Contact System Administrator.

 

Reason : Taken the Application zip file of Pega 7.2 DMSample Application and imported into Pega 7.1.9 Sandbox.

 

Suggested Solutions from Pega : If you have taken any backups, roll down to that backups.

 

Source (Identified) :

  1. Pega is looking for pyCaseHeader rule at runtime and unable to locate it. After analysis, we found that pyCaseHeader rule is not available, So we are getting the issue.
  2. Newly created applications are pointing to UI-Kit-08:01-01-01.

 

Solutions We tried :

  1. Tried to change the UI-Kit version to UI-Kit-07:04-01-01  and the Case creation portal worked fine. But the higher rules needs to be unlocked to delete them and we don’t know the password for those rulesets.
  2. Tried to save as the ruleset UI-Kit-07:04-01-01 to higher version or create new rules but we are unable to do it due to restriction of permissions.

 

Comments :

  1. We don’t have any backups.
  2. Existing applications work fine in the sandbox and we are getting the issues only when we are creating the new applications built on PegaRules or DMSample.
  3. Unable to identify the source for Case Worker and Case Manager portal.

 

 

Later, we have taken the DMSample Application from Pega 7.1.9 Sandbox and imported again into our Pega 7.1.9 Sandbox as per the suggestion from an Associate, From there onwards we are unable to create the application also.

 

We are having a plan to upgrade our Pega sandbox from Pega 7.1.9 to Pega 7.2.1. Please suggest us if there is any method to resolve this issue or is there any chance of resolving this issue by upgrading the Pega sandbox to Pega 7.2.1 from Pega 7.1.9.

***Updated by Moderator: Lochan. Removed user added helpme and Ask the Expert tags. Apologies for confusion, shouldn't have been an end-user option; updated Category; added SR details***

Low-Code App Development Low-Code App Development Upgrades Low-Code App Development Testing Applications SR Exists
Moderation Team has archived post
Share this page LinkedIn