Question

8
Replies
3193
Views
Ravi Kumar Pisupati Member since 2015 73 posts
Optum
Posted: 2 years ago
Last activity: 2 years 5 months ago
Closed
Solved

Unable to render the section using include jsp tag from HTML while accessing it from mobile app

Hi,

We are using PRPC V7.2.2 for our app and our app is running in mobile & desktop versions. We have a requirement to send the PDF in our application. For that, we are using the below steps and is working properly in Desktop version but we see some issues while rendering the sections in the PDF using mobile.

1) We have an activity where it is being called from a utility in the process flow

2) In the above activity, we have a property-set-HTML where we call the necessary section using the HTML rule instance

3) From the HTML rule instance, we are calling the include jsp tag to pull the necessary sections to be shown on the PDF

Eg: <pega:withPage name="pyWorkPage">

<pega:withEmbedded name=".EmbeddedPage1" >

</pega:withEmbedded ><pega:include name="SampleSection_PDF" type="Rule-HTML-Section"/>

<BR/>

</pega:withPage>

4) After rendering the section data, we store it in the param.Markup1

5) This param is used for generating the PDF logic using Call HTMLPDF

6) Sending email after above steps and the attached PDF

All the above steps are running fine in desktop but in mobile side we see the below data in Markup1 as below.

<div data-template-name='pxSection' data-template-instance-id='1517465638928000' CLASS='template-root-marker'><div id='1517465638941000' style='display:none'>

Here all the section data is rendered

Where as in Desktop version, the same Markup1 data is coming like below and the section is getting included properly.

< div data-ui-meta="{'type':'Section','ruleName':'SampleSection_PDF','insKey':'RULE-HTML-SECTION ABC-Data-IMP SampleSection_PDF #20171214T200602.506 GMT'}" class='sectionDivStyle' id='RULE_KEY' node_type='MAIN_RULE' node_name='SampleSection_PDF' data-node-id='SampleSection_PDF' version='1' objclass='Rule-HTML-Section' pyclassname='ABC-Data-IMP' readonly='false' expandRL='' uniqueID='SID1517293702717' >

I am unable to find the root cause for this issue from mobile side. Am I missing anything? Is there anything I need to work on the section and the used elements? Please help me.

Thanks,

Ravi Kumar.

***Edited by Moderator Marissa to update categories***

Low-Code App Development Low-Code App Development Dev/Designer Studio Mobile User Interface SR Created
Moderation Team has archived post
Share this page LinkedIn