Question

2
Replies
39
Views
VenkataG5361 Member since 2015 2 posts
CGI
Posted: 2 years ago
Last activity: 2 years 4 months ago
Closed
Solved

Unable run RPA using PEGA7.3 because of below errors

Hi Team, I am try to run small automation using RPA, but it is failing with below errors. Can someone throw some light to fix the below issues.

Issue1:
Failed to find a 'RULE-OBJ-ACTIVITY' with the name 'PZNOTIFYROBOTICWORKBASKETCONTAINER' that applies to 'Assign-Worklist'; no rules with this name were found in the rulebase.
I understood that 'PZNOTIFYROBOTICWORKBASKETCONTAINER'activity is missing. As per some PDN article I imported 'Pega Robot Manager' zip file to fix the issue, after the import I getting bellow error.
Failed to find a 'RULE-OBJ-ACTIVITY' with the name 'PZNOTIFYROBOTICWORKBASKETCONTAINER' that applies to 'Assign-Worklist'. There were 2 rules with this name in the rulebase, but none matched this request. The 2 rules named 'PZNOTIFYROBOTICWORKBASKETCONTAINER' defined in the rulebase are:
1 related to applies-to class 'Assign-Worklist', but were defined in rulesets which are not in your rulesetlist: 'Pega-Robotic-Console:01-01-02'.
1 unrelated to applies-to class 'Assign-Worklist', for example: 'Data-Admin-WorkBasket'.

Issue2:
ERROR INL-Dy7JTF2|0:0:0:0:0:0:0:1|Rest|api|v1|assignments|A94F4C7CDF52E64C14825CC98C982AE4D - Authorization failed, please contact system administrator.
com.pega.pegarules.pub.PRRuntimeError: PRRuntimeError
at com.pega.pegarules.session.internal.mgmt.bas
here 'INL-Dy7JTF2' is my robotname/system name.

Thanks

Venkat Garapati

Robotic Process Automation
Moderation Team has archived post
Share this page LinkedIn